Show more

Me, earlier: I'm well jet-lagged, I'll just do this quick thing on the laptop whilst I have my dinner.
Me, one macbook pro battery later: It's half eleven you plank, why have you been fighting with docker swarms all evening...

If anyone has any hints (apart from "Don't" for running in a swarm which includes a mac... (swarm manager/portainer server on ubuntu 18.04, portainer manager on 18.10 works fine, agent on MacOS 10.14.4 can't connect to manager)

Just discovered that the convenience store next to my new employer's office stocks both cherry, and cherry vanilla Dr Pepper πŸ˜€
It's £1.49 a can 😭
RIP my teeth, waistline, and bank balance...

MatStace boosted

Purism will allow bigoted content on their servers 

Before spending my week off between employers doing "not much apart from a few longer* walks" I should have checked my May weekends. They're all either travelling or partying, so my newly acquired interest in installing homeassistant and mycroft might have to wait...

*only a few miles, but for someone who has done basically no exercise since the Jan 22nd...

MatStace boosted

#mastoAdmin

bsd.network has blocked the librem.one instance, because they removed all abilities for us to report abuse to them. They also removed the ability for their users to report abuse from our users, which is also pretty troublesome.

While we normally do not announce instance blocks, this is a fairly serious action on their part and needs to be pointed out publicly.

The safety of our users in the Fediverse is very important to us.

MatStace boosted

I love the idea of the hackerfarm - I've had a longtime distant dream of a vaguely off-grid/sustainable place in the country, but to combnie that with decent internet and what is basically a hackspace... Oh my... makery.info/en/2015/08/11/hack

@beehive Are there any debug options I can turn on?
Specifically to get to the bottom of an auth problem with the mastodon bee, where I think my email address having a plus sign in the username is causing it to fail authentication

Yesterday was the last day in what is now my old job, and I'm now a man of leisure until my new job starts on the 6th May.

So far, I've managed to take too much time away from chores by arranging all the socialising, and now I want to also learn enough go to make an MQTT Bee for @beehive

Maybe that can be my backup evening filler for week 1 of new job, when I'll be a in a hotel, in case I don't fancy getting out and about in New York ;-)

MatStace boosted

Answering my own question, the "not yet compatible" apps are disabled, with an option to YOLO it, warning that they may not work as expected.

The more I use, the more impressed I am.

As a relative newcomer to version 16 is my first major upgrade, does anyone know what happens with apps which haven't yet got an upgrade available for that version?
Is it just a case of a file somewhere says "compatible with > 15.X" and the app will _probably_ still work?

MatStace boosted

Not that I'm clock-watching or anything, but is it the end of working hours yet?

How much do I hate myself that not only have I just watched the cobra Kai TV show, but looking into offline email for my phone (seriously fastmail, sort it out...) I ended up almost installing mutt inside termux...

Me, who considers himself a professional at what he does: "Oh Hai AWS Support, this doesn't looks like it's working, here are lots of resource IDs, and everything I've done, and what isn't working"

AWS Support, an actual professional: "I can't see into the other account you mentioned, because security, but could you double check X"

Me, an idiot: "Yes, that was it, thank you"

I haven't seen much chatter on the fediverse, but I'll throw out my trainer code anyway, in the hope that I might add some in-game friends for gifting etc (there are some good XP gains to be made by hitting the upper friendship levels. One day I'll make it to level 40...)
Add me here: 0587 3388 9093

After six years, I think it's definitely time to destroy my first digitalocean droplet. The only things hitting the webserver now are bots and script kiddies.
Also, debian 7 and php 5.4 (I forgot to double check the nginx version before I destroyed it, but I assume it isn't particularly up to date πŸ˜‚ ), it's probably wise to run something a little newer... You know, something with native IPv6 instead of an he.net tunnel.

Show more
Octodon

Octodon is a nice general purpose instance. more